Compatibilité 1.7.0Compatibilité 1.7.0

Détails de compatibilité du jeu

Tableau de compatibilité
Nom du jeu Identifiant Niveau de support
Fascination fascination Excellent
No known issues. Game is completable
- Amiga, Atari and DOS versions are supported by this target

 

Tentacle